Page 30 of 33

Re: Eurobilltracker-site Feedback.

Posted: Wed May 23, 2018 2:31 pm
by Juliento
avij wrote:
Wed May 23, 2018 5:30 am
avij wrote:
Mon May 21, 2018 7:27 pm
OK, so this may be browser-related. Of course I don't have any computers capable of running Edge here at home. Can you see the version number or build number of Edge somewhere?
This would still be useful to know. As for fixing, let's try the easiest approach first. See if there are any updates available for Windows/Edge and install them if available. You may need to restart your computer afterwards. If this does not help we'll need to dig deeper.
Hello avij, I will be able to check the version of Edge on the computer on saturday or sunday.

Re: Eurobilltracker-site Feedback.

Posted: Wed May 23, 2018 8:19 pm
by ErGo
I made some note entries on the test server with an Edge-Browser version 42.17134.1.0. There i have the same problem - but only on the advanced form - not on the expert form.

Re: Eurobilltracker-site Feedback.

Posted: Sat May 26, 2018 5:27 pm
by Juliento
Juliento wrote:
Wed May 23, 2018 2:31 pm
avij wrote:
Wed May 23, 2018 5:30 am
avij wrote:
Mon May 21, 2018 7:27 pm
OK, so this may be browser-related. Of course I don't have any computers capable of running Edge here at home. Can you see the version number or build number of Edge somewhere?
This would still be useful to know. As for fixing, let's try the easiest approach first. See if there are any updates available for Windows/Edge and install them if available. You may need to restart your computer afterwards. If this does not help we'll need to dig deeper.
Hello avij, I will be able to check the version of Edge on the computer on saturday or sunday.
Version of Edge installed is :

Capture.PNG
Capture.PNG (4.93 KiB) Viewed 765 times

There is no update available.

Re: Eurobilltracker-site Feedback.

Posted: Sun May 27, 2018 8:58 am
by Sneakster
I ran into the same issue here. Today I had a bunch of 37 notes alltogether, which is normally inserted in no time.
This time it took me about 10 minutes, starting out with the advanced entryform.
Got the message: invalid note entry, so started over again with the single note entry, even then I had to try up to two times for one single note before
it was finally accepted. I entered a € 50,- note, which showed up in my noteslist as a € 500,- 8O
I corrected that, just in case you wondered :wink:
The Edge version I use is also 42.17134.10, which I am running since last tuesday

Re: Eurobilltracker-site Feedback.

Posted: Mon May 28, 2018 7:42 pm
by avij
I still haven't had the possibility to test this myself, but I have now implemented a partial workaround for the problem. If the entered denomination is not valid (like 5k) but the denomination string where the last character has been chopped off is, the chopped denomination string will be used instead. Note that it is possible that the randomly added character is 0 (zero), in which case this workaround can't distinguish between 5, 50 and 500, 10 and 100, and 20 and 200. I believe this is fairly rare (the above message from Sneakster is one of those rare cases), so for most cases this workaround should work.

Edit: Changed the conversion to a simple intval($denomination) after all, because despite using mb_substr it did not understand how to deal with denominations such as 5䀂. The above disclaimer about a possible trailing zero is still valid with this intval() approach.

Edit2: Now using both intval and substring methods to also cover cases like 205, which plain intval won't change.

Re: Eurobilltracker-site Feedback.

Posted: Tue May 29, 2018 11:37 am
by Crazy Bob
avij wrote:
Mon May 28, 2018 7:42 pm
I still haven't had the possibility to test this myself, but I have now implemented a partial workaround for the problem. If the entered denomination is not valid (like 5k) but the denomination string where the last character has been chopped off is, the chopped denomination string will be used instead. Note that it is possible that the randomly added character is 0 (zero), in which case this workaround can't distinguish between 5, 50 and 500, 10 and 100, and 20 and 200. I believe this is fairly rare (the above message from Sneakster is one of those rare cases), so for most cases this workaround should work.

Edit: Changed the conversion to a simple intval($denomination) after all, because despite using mb_substr it did not understand how to deal with denominations such as 5䀂. The above disclaimer about a possible trailing zero is still valid with this intval() approach.

Edit2: Now using both intval and substring methods to also cover cases like 205, which plain intval won't change.
Let me know if you need tests with strange characters in the denomination field, I'm happy (and able) to help :lol:

Re: Eurobilltracker-site Feedback.

Posted: Tue May 29, 2018 6:40 pm
by avij

Re: Eurobilltracker-site Feedback.

Posted: Wed May 30, 2018 6:07 pm
by avij
The Edge saga continues. The above bug report states that one workaround would be to make some slight changes to the dropdown menu HTML code. I was a bit concerned about making that change, because due to how the form HTML is constructed in EBT, the change would affect nearly all dropdown menus sitewide and not only the note entry forms. Nevertheless, I have now made that change and nothing seems to have broken yet. Please let me know if something related to dropdown menus broke this evening.

Re: Eurobilltracker-site Feedback.

Posted: Tue Jun 05, 2018 3:30 pm
by trezay
Hi, this is not a major issue, but I thought it might be worth mentioning, since it could confuse new users. I was showing the EBT website to a friend of mine and wanted to explain what printer codes were. I noticed that the explanations about where to find printer codes are not up to date. Both the simple note entry page and the FAQ give a description for the 2002 series of notes, but not for Europa notes.

Re: Eurobilltracker-site Feedback.

Posted: Wed Jun 06, 2018 9:58 am
by LArdennais
And in the same FAQ-page, the subject "Year of print" should also be updated.

Re: Eurobilltracker-site Feedback.

Posted: Thu Jun 07, 2018 6:10 pm
by lmviterbo
Here's my suggestion for the English text (anyone who knows the English language better than myself, please feel free to correct me):

The printer code is somewhat hidden. It is always printed on the front of the note, the same side where the year is found and not where the serial number is. Look for a very small sequence of letters and digits, e.g. 'R001A1'.
On the older notes (1st series):
* 5 €: in the far left of the colored area, 1cm above the O in EURO
* 10 €: in the star, to the top-right of the O in EURO
* 20 €: in the leftmost star
* 50 €: above the hologram
* 100 €: the first word of the text between the window and the stars
* 200 €: to the right of the south-western star, written vertically
* 500 €: in the leftmost star.
On the newer notes (Europa series):
* all denominations: top right, between the window or doorway and the hologram (silvery stripe)



Furthermore, I suggest that the whole paragraph about "Year of print" (which in fact should be "Year of issue") is deleted.

Re: Eurobilltracker-site Feedback.

Posted: Wed Jun 13, 2018 3:38 pm
by GWR7007
Not really some feedback regarding the site itself but rather the forum. Maybe there is a specific thread for such issues but a quick search did not give me a result :oops:

It's a bit irritating for me that PMs are not saved as drafts when writing on them. I was writing a PM to a user I keep in contact with via PM and after writing a part, I wanted so see how my answer looked like up to that point. I normally cite a lot of parts of his message to give an answer to that part. When clicking on "preview" somehow I was not logged in anymore and after logging in again the text of the message was gone.
This is not the first time this happened unfortunetly and it is strange because sometimes I am logged in for hours, can refresh (I'm not that familiar with "computer-English", I'm afraid but I think it's called that way) the page as much as I want to and everything works fine. Contrary to that, there are moments where I write a message either as PM or as "normal", public message and I have to log in again before I can post it although I'm just logged in for a very short time.

Especially with longer PMs this is rather annoying as I put quite some time in the writing of those PMs and I'm not very keen on writing everything again :evil:

So the point is: would it be possible to save a PM as draft automatically every couple of minutes to avoid such situations? Or is this not a "problem" of the forum but somewhere on my side ?

Re: Eurobilltracker-site Feedback.

Posted: Wed Jun 13, 2018 6:43 pm
by trezay
GWR7007 wrote:
Wed Jun 13, 2018 3:38 pm
Sometimes I am logged in for hours, can refresh (I'm not that familiar with "computer-English", I'm afraid but I think it's called that way) the page as much as I want to and everything works fine. Contrary to that, there are moments where I write a message either as PM or as "normal", public message and I have to log in again before I can post it although I'm just logged in for a very short time.
I get the same problem, I'm not sure if it's a problem with my computer or with the forum. I often get logged out when I click on "Preview", and when I log back into the forum, whatever I had written is lost. I just chose the lazy solution :oops: I copy the text of my post before I hit "Preview", so I can paste it if I get disconnected.

Re: Eurobilltracker-site Feedback.

Posted: Wed Jun 13, 2018 7:05 pm
by GWR7007
trezay wrote:
Wed Jun 13, 2018 6:43 pm
I just chose the lazy solution :oops: I copy the text of my post before I hit "Preview", so I can paste it if I get disconnected.
Possible, yes. However, I think there should be some solutuion. If I remember it correctly, all emails I write are saved as draft every 2 or 3 minutes :lol: . That means, that it is at least somehow possible.

Anyway: I'm quite happy that I am not the only one who has this problem :|

Re: Eurobilltracker-site Feedback.

Posted: Wed Jun 13, 2018 7:48 pm
by trezay
Oh, I agree, there probably is a better solution :wink: I wasn't posting that message to contradict you. I just wanted to mention that I was having the same issue, so that whoever can help with this knows that it isn't an isolated thing.